FindDrivers.jpg

Нередки случаи, когда в компьютере под Линуксом «из коробки» не работает пара устройств. Причиной этого может быть слишком новое железо, отсутствие Линукс-драйверов от производителя устройств, устаревшее железо, несовместимость устройств или брак. По данным сайта Linux-Hardware.org не менее 10% пользователей Линукс сталкиваются с подобными проблемами. Согласно нашей статистике наиболее проблемными устройствами являются:

Если устройство не работает, то это не означает, что его нельзя заставить работать. Иногда можно найти более подходящее ядро или сторонний драйвер для устройства в интернете. Для поиска нужного ядра можно воспользоваться базой данных LKDDb, в которой проиндексированы поддерживаемые устройства для каждой версии ядра или поискать решение на форумах и подобных ресурсах.

Сегодня мы запускаем новый способ поиска драйверов — с помощью создания пробы компьютера! Если для какого-то устройства в вашей пробе не был загружен драйвер, то для него будет предложена подходящая версия ядра или известные сторонние драйверы. Эта же информация представлена на странице каждого PCI/USB устройства в базе.

Пробу можно создать следующей командой (для других дистрибутивов есть AppImage):

   hw-probe -all -upload

Поиск драйвера осуществляется по базе LKDDb для ядер начиная с версии 2.6.24 и до самой новой 5.0. Также мы проиндексировали следующие сторонние драйвера:

Да, мы проиндексировали fglrx для старых графических карт AMD/ATI. В некоторых случаях производительность с ним может быть выше, чем при использовании свободного драйвера radeon, но для этого надо будет поставить предыдущую версию Росы R8, так как в более новых версиях системы fglrx не поддерживается.

Это не единственный пример, когда нужно не обновление ядра, а откат на предыдущую версию. Для некоторых устройств драйвера устаревают и их просто выкидывают из ядра. В таких случаях вам нужно подобрать одну из старых версий вашего дистрибутива со старым ядром, обновив затем вручную необходимые программы (например, браузер).

Всем спасибо за внимание!

VK: https://vk.com/rosa_linux?w=wall-33847957_285897.

Compatibility.png